Obsah

 Nahoru Další

Seznámení s aplikací Editor tiskových sestav

Základ

• Definice pojmů
• Oblast tiskové sestavy (report bands)
• Prvky tiskové sestavy (Report elements)

Tvorba sestavy

• Tvorba nové sestavy s průvodcem
• Vložení nových prvků do sestavy
• Úprava vlastností prvků sestavy
• Tlačítková lišta
• Použití myši
• Použití klávesnice

Databáze

• Nastavení databáze

Příklady krok-za-krokem

• Úprava existující sestavy
• Jednoduchý seznam adres
• Pokročilý seznam adres

Prvky sestavy a jejich vlastnosti:

Oblasti tiskové sestavy

• Standardní oblasti (zahlaví, detail...)
• Oblast Poddetail
• Oblast Skupina
• Oblast Dítě

Prvky tiskové sestavy:

• Datové pole
• Nadpis - text
• Víceřádkový text
• Obrázek
• Obrázek z databáze
• Výpočtové pole
• Tvar
• Systémové pole
• Richtext - formátovaný text
• Richtext z databáze

Pokročilá témata

• Formátování číselných, datumových nebo časových polí
• Výpočtové syntaxe
• Používání parametrů v SQL dotazech

Další

• Menu "Zobrazit | Volby"
• Položka menu "Sestava | Volby"
• Otázky a odpovědi, tipy a triky


Definice pojmů

 Nahoru Předchozí Další

Sestavy a databáze

Sestava

Pojem "sestava" popisuje výpis datových záznamů z databáze. Sestava definuje vzhled tisku (rozložení, písma, uspořádání datových polí, atd.). Například, pokud chcete vytisknout seznam adres, můžete použít sestavu určení, která pole databáze adres tisknout a v jakém pořadí. Sestava může vytisknout data jako seznam, stránku po stránce nebo jakýmkoliv jiným způsobem jak chcete aby vaše data byla vytištěna.

Tabulka

Soubor se záznamy stejného typu se nazývá tabulka, např. soubor s informací o adrese nebo položky faktury. Tabulka může být jeden soubor, například dBASE nebo Paradox souboru, nebo může být součástí databáze (viz níže).

Dotaz

Dotaz se skládá z příkazů SQL, které se používají pro přístup do tabulky nebo databáze a získání skupiny datových záznamů. SQL znamená "Structured Query Language" a je jakýmsi programovacím jazykem pro databáze. Kompletní popis SQL je mimo rozsah tohoto manuálu, ale existuje mnoho knih na toto téma k dispozici.

Dataset

Označení Dataset se používá jako souhrnný název pro tabulky a dotazy.

Databáze

Dotazy a tabulky mohou být seskupeny do databáze, která může být lokální soubor na vašem pevném disku nebo databázový server v síti. Pro přístup lze zvolit buď svůj adresář, pokud se jedná o jediný soubor, nebo budete potřebovat název databáze v případě, že tabulka je součástí databáze.

Alias

Aliasy jsou popisné názvy k dispozici jako zástupné symboly pro cesty nebo databáze.


Oblast tiskové sestavy

Obrázek níže ukazuje první stránku sestavy, která tiskne názvy zemí, jejich hlavních měst a jejich obyvatel. Tato sestava může být rozdělena do několika oblastí:

Tyto části slouží pro návrh sestavy a jsou nazývány "oblasti" (angl. BAND). Jde o souvislé pruhy v sestavě. Například "Pata stránky" (Page Footer) je pro všechny texty v zápatí stránky a "Záhlaví sestavy" (TITLE) pro úvodní texty na první stránce. Nejdůležitější oblast je "Detail". Oblast Detail je vytištěn jednou pro každý datový záznam (pro každou zemi ve výše uvedeném příkladu), čímž vytiskneme seznam údajů. Obsah oblasti Detail je stejný pro každý záznam a proto musí být vytvořen pouze jednou pro celou sestavu (pro jeden záznam), se prvky pro každého datového pole. Každá položka umístěná v oblasti Detail je pak při tisku nahrazena daty z aktuálního záznamu dat.


Prvky tiskové sestavy

Prvky tiskové sestavy (Report elements)

 Nahoru Předchozí Další

Kromě sekcí se může sestava rozdělovat ještě do logických celků. Zde se pak umisťují jednotlivé prvky sestavy.

Dva nejdůležitější prvky jsou "nadpis" (štítek, popisek) a "datové pole". Nadpisy se používají pro tisk textu - například titul - jde o statické texty, jejichž obsah není připojen k databázi. Datová pole jsou naproti tomu zástupné symboly pro sloupce z datového souboru. Kdykoliv se tiskne datové pole, sestava zjistí potřebný text z databáze a ten vytiskne.

Obvykle se nadpisy tisknou jako návěští datových polí. Tím se usnadňuje orientace v tiskové sestavě.

Následující obrázek ukazuje sestavu která vytiskne seznam včetně nadpisů pro každý sloupec.

Typy prvků které jsou k dispozici při navrhování tiskové sestavy:

• Datové pole - k zobrazení textu z datové sady

• Nadpis, popisek - pro zobrazení pevného textu

• Systémové pole - datum, čas, číslo stránky, ...

• Tvary - kruh, obdélník, čára

• Obrázek - obrázek umístěný v počítači

• Obrázek z datového pole - obrázek umístěný v databázi

• Výpočetní pole - matematické, logické výpočty, ...

• Dlouhý text - text s více řádky

• RichText RTF - formátovaný text

• RichText RTF z datové pole

Každý prvek sestavy má své specifické vlastnosti (písmo, barvu, ...), které můžete upravovat.


Tvorba nové sestavy s průvodcem

Vyberte v menu položku "Soubor | Nový", nebo stiskněte odpovídající tlačítko v tlačítkové liště. Zobrazí se průvodce, s jehož pomocí můžete rychle navrhnout jednoduchou tiskovou sestavu.

Nejprve je nutné vybrat jaký typ sestavy chcete vytvořit, který datový soubor používat a jaké bude rozložení v sestavě. Potřebné prvky sestavy budou automaticky vytvořené v sestavě. Poté, co bude průvodce dokončen, můžete pokračovat v editaci sestavy dle vašich představ.
Zvolíte-li "Novou prázdnou sestavu" bude vytvořena zcela prázdná tisková sestava. Pak je nutné ručně přidat všechny oblasti a prvky.


Vložení nových prvků do sestavy

Tlačítka pro přidávání prvků do sestavy naleznete v levé nástrojové liště

btn1 Oblast sestavy

btn2 Oblast Dítě

btn3 Oblast Poddetail

btn4 Skupinová oblast

btn5 Popisek

btn6 Dlouhý text

btn7 Obrázek

btn8 Tvar

btn9 Systémové pole

btn10 Výpočetní pole

btn11 Datové pole

btn12 Obrázek z databáze

btn13 Richtext pole

btn14 Richtext z databáze

Chcete-li přidat prvek do sestavy, musíte kliknout na tlačítko a pak klikněte na sestavu v místě, kam chcete prvek vložit. Samozřejmě vždy můžete přesunout prvek na jinou pozici.

Při přidávání nové oblasti do sestavy nezáleží na tom, kde kliknete na sestavu, protože poloha každé oblasti je dána již typem oblasti (záhlaví stránky, sumář, ...) automaticky.


Úprava vlastností prvků sestavy

Jednotlivé vlastnosti prvků sestavy mohou být změněny kdykoliv v průběhu tvorby sestavy. Vyberte požadovaný prvek a dvakrát poklepejte levým tlačítkem myši, nebo stiskněte pravé tlačítko myši a zvolte "Vlastnosti" z kontextového menu. Otevře se okno pro úpravu vlastností prvku (stejné jako při vkládání nového prvku). Následující obrázek ukazuje okno pro úpravu vlastností prvku "popisek":

Upravte vlastnosti prvku podle Vašich potřeb a stiskněte tlačítko "OK" pro uložení změn. Pokud stisknete "Storno", jsou všechny změny zrušeny, a pokud právě vkládáte nový prvek nebude vůbec vytvořen.

Informace o vlastnostech pro každý prvek sestavy lze nalézt v popisu jednotlivých prvků


Nástrojová lišta

Mnoho vlastností prvků sestavy můžete změnit také přímo v horním panelu nástrojů. Navíc můžete nástrojovou lištu použít k úpravě vlastností u více vybraných prvků najednou.

Tlačítka pro vytvoření nové sestavy, otevření sestavy ze souboru a uložení sestavy.

Pomocí těchto tlačítek můžete sestavu vytisknout nebo zobrazit náhled.

Tlačítka pro práci se schránkou Windows - vyjmout, kopírovat, vložit.

Tato tlačítka použijete pro přesun prvku na pozadí nebo do popředí v případě, že se dva prvky překrývají.

Prvky sestavy je možné uspořádat, vyrovnat a vystředit pomocí těchto tlačítek. Některá tlačítka jsou aktivní pouze tehdy, když je vybráno více prvků (například zarovnání k okraji).

Tato část panelu zobrazuje typ aktuálně vybraného prvku či oblasti. Pokud jde o prvek typu "popisek" je možné přímo měnit zobrazený text. Pokud jde o datové pole můžete měnit zobrazovaný sloupec z tabulky a pokud jde o oblast, její typ.

Zde si můžete nastavit písmo a jeho styly vybraného prvku sestavy (název písma, velikost písma, tučné, podtržené, kurzíva).

Tlačítka pro zarovnání textu v rámci prvku sestavy. Text může být zarovnán vlevo, vpravo nebo na střed. Samozřejmě, že tato vlastnost má smysl jen tehdy, jestliže je prvek sestavy větší než zobrazovaný text a pokud je vlastnost "automatická velikost" deaktivována.

Pomocí tohoto tlačítka můžete otevřít okno pro nastavení orámování vybraného prvku.


Použití myši

Výběr prvku zprávy

Prvek sestavy lze vybrat klepnutím levým tlačítkem myši. Výběr je zobrazen s osmi malých černých čtverečky kolem prvku:

Změna velikosti prvku

Můžete použít malý čtvereček vybraného prvku pro změnu jeho velikost. Je-li kurzor myši umístěn nad čtvereček, kurzor změní na šipku jakým směrem je možné měnit velikost prvku.

Upozornění: Oblastem sestavy je možné měnit pouze výšku zatímco šířka je pevně nastavena automaticky.

Výběr více prvků (a)

Můžete si vybrat více prvků podržením klávesy [Shift] s levým tlačítkem myši.

Výběr více prvků (b)

Podržte [Ctrl] spolu s levým tlačítkem myši a přetáhněte rámeček přes prvky, které chcete vybrat. Po uvolnění tlačítka myši budou všechny prvky uvnitř rámu označené.

Přesunout prvky

S vybranými prvky lze pohybovat levým tlačítkem myši. Podržte tlačítko myši, přetáhněte prvek na požadované místo a uvolněte tlačítko myši. Oblasti sestavy nelze přesunout, protože jsou umístěny automaticky v závislosti na jejich typu.

Přesun a změna velikosti prvků bez ohledu na aktuální nastavení mřížky

Pokud chcete manipulovat s prvkem sestavy bez ohledu na aktuální mřížky (menu "Zobrazit | Možnosti") a přesunout nebo změnit jeho velikost o jeden pixel, podržte klávesu [Shift] a současně pohybujte myší.

Upravit prvek vlastnosti

Pokud klikněte dvakrát na prvek sestavy levým tlačítkem myši, nebo pokud zvolíte položku "Upravit" z kontextového menu prvku (který je dostupný pravým tlačítkem myši), bude zobrazeno okno pro změnu všech vlastností prvku.


Použití klávesnice

Editor sestav se ovládá většinou myší. Některé funkce mohou být přístupné také pomocí klávesnice:

Enter

Zobrazení vlastností prvku

Kurzorové klávesy

Přesun prvku sestavy

Shift + kurzorové klávesy

Změna velikosti prvku sestavy

Delete

Smazání prvku sestavy

Tab and Shift + Tab

Vybrat další nebo předchozí prvek sestavy


Databáze

Ve většině případů musí mít každá tisková sestava připojen alespoň jeden datový soubor, který dodává záznamy pro tisk sestavy. Všechny datové soubory můžete definovat prostřednictvím nastavení databáze (menu "Sestava | Tabulky databáze").

Poznámka: Tlačítko "vlastnosti" zobrazí nastavení aktuálně vybrané tabulky nebo dotazu. Pokud jsou ovládací prvky tohoto okna nepřístupné, namáte povoleno měnit nastavení databáze.

Toto okno ukazuje hlavní datový soubor sestavy ze kterého tisková sestava čerpá záznamy. Pod hlavní tabulkou je seznam všech dostupných tabulek. V ukázkovém okně existuje pouze jedna tabulka která je zároveň hlavním datovým souborem sestavy, ale je možné přidávat další tabulky či dotazy.

Chcete-li přidat tabulku nebo dotaz, použijte tlačítko "Nový".

Nová tabulka:

Pokud stisknete toto tlačítko zobrazí se následující okno (ovšem pouze v případě, že máte povoleno přidávat nové tabulky)

Jedná se o okno, kde můžete vybrat požadovanou tabulku.

Nový dotaz:

Následující dialogové okno se otevře, když stisknete "Nový" a vyberete možnost pro tvorbu nového dotazu.

Zde můžete vytvořit dotaz v jazyce SQL. Pokud má Váš dotaz parametry, můžete nastavit jejich hodnoty přes tlačítko "Paramtery". Pokud se mají parametry získávat z jiného datového souboru, vyberte tuto tabulku nebo dotaz v políčku "řídící".

Datových polí:

Zvolíte-li tlačítko "Pole", zobrazí se seznam všech dostupných polí (sloupců) aktuálně vybraného datového souboru.

Poznámka: Tlačítka v tomto dialogu jsou nedostupná, pokud nejsou povoleny úpravy polí datového souboru.

Můžete odstranit (skrýt) nekterá pole z datového souboru (nebudou k dispozici při tvorbě sestavy), nebo můžete upravit vlastnosti pole sloupce:

Zobrazení návěští (popisku) je možné nastavit pro každé datové pole, které se používá jako alias při tvorbě sestavy. Tímto způsobem můžete mít zobrazené názvy polí, i když je fyzicky datový soubor nemá, například "ZakNo" může být nahrazen "zákazník".

Pomocí "formátu" je možné upravit formát číselných polí (viz Formátování numerické pole).

"Přesnost" určuje, kolik bude zobrazeno číslic za desetinnou čárku.


Úprava existující sestavy

Tato kapitola ukazuje jednoduchý příklad použití Designéru Sestav. Stávající sestava, databáze, oblasti tisku a tiskové prvku byly již vytvořené a nyní je možné je upravovat. Podívejte se na následující příklad:

Tato sestava vytiskne data v následujícím rozložení:

Změna výšky tisknutých řádků:

Řekněme, že datové linky jsou příliš blízko a chcete, aby byly dále od sebe. Každý řádek má stejnou šířku jako má nastavená tisková oblast. Pro každý datový záznam je jednou vytištěna oblast "detail", takže pokud změníte výšku oblasti "detail", zvětší se i prostor tisku každého datového záznamu. V návrhu sestavy proto vyberte oblast "detail" kliknutím levým tlačítkem myši. V rozích se objeví malé černe čtverečky, které se používají pro změnu velikosti tiskových prvků. Klikněte levým tlačítkem čtvereček umístěný v dolní části oblasti a táhněte směrem dolů. Tímto způsobem změníte výšku oblasti "detail"

Nyní můžete stisknout tlačítko "Náhled" nebo zvolte "Soubor | Náhled" pro kontrolu zobrazení.

Přesun tiskových prvků:

Možná se vám nelíbí umístění některých prvků sestavy, a například chcete první datové pole umístěné trochu více vpravo. Pozici můžete změnit tím, že prostě kliknete na datové pole levým tlačítkem myši a přetáhnete prvek do nové pozice. Pamatujte však, že nemůžete přesunout prvky do jiné oblasti tiskové sestavy. Také není možné pohybovat celou tiskovou oblastí, protože jeji poloha je určena automaticky typem oblasti (např. záhlaví stránky v horní části stránky apod).

Změna písma:

Pokud chcete změnit písmo prvku sestavy, nejprve jej vyberte (můžete také vybrat více prvků najednou) a pak změnte hodnotu v horním panelu nastavení písma:

Můžete si vybrat název písma, velikost písma a styl (tučné, podtržené, kurzíva). Seznam písem závisí na instalovaných fontech ve vašem počítači.

Přidání a změna popisku:

Chcete-li vložit statický text do vaší sestavy stiskněte tlačítko "popisek" btn5. Po stisknutí tlačítka klikněte na sestavu do místa, kde chcete přidat nový text. Zobrazí se okno pro vyplnění vlastností nového popisku, kde můžete napsat text a nastavit některé další možnosti. Po stisknutí tlačítka OK bude text vložen do sestavy a později bude vytištěn v této poloze.

Pokud chcete změnit text (nebo jinou vlastnost, například zarovnání textu) na stávajícím popisku, vyberte tiskový prvek levým tlačítkem myši a otevřete znovu okno pro změnu vlastností prvku. A to buď dvojklikem nebo výběrem položky "Opravy" z kontextové nabídky (přístupné přes pravé tlačítko myši).


Jednoduchý seznam adres

Tato kapitola je návod jak krok-za-krokem vytvořit jednoduchou sestavu, která vytiskne seznam adres. Je použitá datová tabulka, která obsahuje všechny adresy záznamy. Pokud nechcete vytvořit kompletní novou sestavu ale pouze změnit stávající sestavu, můžete přeskočit první krok.

Krok 1: Vytvoření nové sestavy s pomocníkem

Krok 2: Úprava sestavy

Krok 3: Náhled a uložení sestavy


Krok 1: Vytvoření nové sestavy s pomocníkem

Zvolte menu "Soubor | Nový", nebo stiskněte odpovídající tlačítko na horní liště. Okno pomocníka vám pomůže vybrat typ sestavy, kterou chcete vytvořit. Pro náš příklad chceme vytisknout seznam adres, takže použijeme "Styl výpisu":

Stiskněte tlačítko "Další". Nyní můžete nastavit hlavního zdroje dat sestavy.

Na další stránce pomocníka, musíte vybrat, které sloupce tabulky se mají použít. Vyberte sloupce, které se do sestavy mají vložit automatisky. Můžete přetáhnout sloupce z jednoho seznamu do druhého pomocí myši, nebo můžete použít tlačítka nacházející se mezi seznamy. V pravém seznamu můžete přetáhnout sloupce nahoru a dolů pomocí myši měnit tím jejich pořadí.

Další stránka pomocníka vám umožňuje vybrat oblasti sestavy, které chcete použít:

Poté si můžete nastavit některé obecné vlastnosti, například kolik sloupců by měla sestava mít:

Následující stránka určuje vzhled sestavy. Můžete nastavit výchozí písmo pro textová a datová pole, a určit zda se mají tisknout linky mezi sloupci a řádky:

Nyní je sestava nastavena. Můžete si buď vybrat "Ukončení" pro návrat na editor sestav, kde můžete upravit vytvořenou sestavu a uložit, nebo můžete vybrat "Náhled" chcete-li zkontrolovat sestavu před vytištením. Uvidíte náhled sestavy na obrazovce, jak by měla být vytištěna. Pokud se vám nelíbí to, co vidíte, můžete použít tlačítko "Zpět" pro změnu nastavení.

Pokračovat na Krok 2: Úprava sestavy


Krok 2: Úprava sestavy

Náhled:

Nyní jste v editoru sestav a můžete vidět rozložení sestavy. Stisknutím tlačítka "Náhled" [image] získáte první tiskový pohled na výslednou sestavu, pokud jste tak již neučinili při ukončení práce s pomocníkem tvorby sestavy.

Změna nadpisu sloupce:

Jak vidíte, titulky pro datová pole "Addr1" a "Addr2" nevypadají dobře. Pomocním tvorby sestav vytvořil popisky sloupců automaticky, což nemusí vést vždy k optimálním výsledkům. Chcete-li to změnit, opusťte tiskový náhled a vyberte požadovaný prvek (popisek) levým tlačítkem myši. Nyní můžete upravit text popisku buď přimo v horní liště, nebo dvojklikem otevřít okno pro úpravu vlastností prvku.

Upravte text prvku a zadejte více popisný text pro záhlaví sloupce, například "Adresa". Klikněte na "OK"

Změna velikosti a umístění:

Pokud se vám nelíbí rozmístění prvků sestavy, můžete jimi jednoduše pohybovat levým tlačítkem myši (celé tiskové oblasti nelze presunovat).

Chcete-li změnit velikost prvku, nejprve jej vyberte a přetáhněte jeden z osmi malých černých čtverečků po obvodu prvku.

Přidat další prvek do sestavy:

Pro demostrační účel přidáme nyní do tiskové sestavy kruh kolem nadpisu sestavy. Klikněte tedy na tlačítko btn8 chcete-li vložit tvar.

Nyní klikněte na oblast sestavy, která obsahuje nadpis sestavy. Není důležitá přesná pozie kam kliknete, protože můžete snadno pohybovat prvkem i později. Nyní se objeví okno pro zadání vlastností prvku. Zvolte tvar "kruh"

Ješte klikněte na tlačítko "barva" v sekci "štětec" a zvolte např žlutou barvu. Po kliknutí na tlačítko "OK" bude na sestavě zobrazen žlutý kruh (nebo elipsa).

Bohužel kruh z části zakrývá hlavní nadpis sestavy. Stiskněte tlačítko [image] z panelu nástrojů v horní části okna. Tím přesunete kruh do pozadí.

Ještě nevypadá dobře, protože bílé pozadí štítku překrývá kruh. Otevřete okno pro změnu vlastností nadpisu (pravé tlačítko myši, "Upravit") a aktivujte možnost "Průhledné". Pozadí nadpisu bude nyní transparentní (není to ale vidět v návrhovém režimu, ale pouze při opužití náhledu na tisk):

Konečně ješte přesuneme nadpis do středu kruhu. Nejprve vyberte nadpis jako kliknutím myši a pak při podržené klávese [Shift] klikněte ještě na kruh. Tím se vybere více prvků najednou:

Nyní stiskněte tlačítko [image] pro horizontální vycentrování prvků.

Vycentrování lze provést také kliknutím na tlačítko [image] .

Pokračovat na Krok 3: Náhled a uložení sestavy


Krok 3: Náhled a uložení sestavy

Při vytváření sestavy můžete kontrolovat výsledný tisk pomocí volby "Soubor | Náhled" nebo stiskem tlačítka náhled [image]. Sestava se zobrazí na obrazovce tak, jak bude vypadat vytištěna a můžete zkontrolovat celkový vzhled.

Pokud jste hotovi s úpravou sestavy, stiskněte tlačítko save pro uložení sestavy


Pokročilý seznam adres

Předchozí příklad ukázal, jak vytvořit jednoduchou zprávu pomocí průvodce. Pro lepší porozumění tvorbě sestav a účelu jednotlivých typů oblastí, nyní vytváříme sestavu od nuly bez průvodce.

Krok 1: Vytvoření nové zprávy

Krok 2: Nastavení databáze

Krok 3: Vytvoření oblasti Detail

Krok 4: Přidání oblasti Skupina

Krok 5: Záhlaví stránky, názvy oblastí a celkové součty


Krok 1: Vytvoření nové zprávy

Vyberte "Soubor | Nový", nebo stiskněte příslušné tlačítko pro vytvoření nové zprávy. Zobrazí se okno průvodce ale vyberte volbu "Nová prázdná sestava". Nyní stačí stisknout tlačítko "Pokračovat", a průvodce bude ukončen.

Pokračujte na Krok 2: Nastavení databáze


Krok 2: Nastavení databáze

Přidání datového souboru:

Nejprve musíme nastavit sestavě hlavní datový soubor. Zvolte menu "Sestava | Tabulky databáze". Vyberte tabulku nebo vytvořte nový dotaz (pokud to zobrazené okno umožňuje)

Hlavní tabulka sestavy:

Vzhledem k tomu, že lze využívat více tabulek je nutné přiřadit sestavě hlavní tabulku. Tzv řídící tabulku podle níž se je řízen tisk od prvního do posledního záznamu. Pomocí výběrového pole v horní části okna vyberte tuto tabulku.

Pokračovat na Krok 3: Vytvoření oblasti Detail


Krok 3: Vytvoření oblasti Detail

Vložení oblasti Detail

Poté, co jste vybrali tabulku pro sestavu, musíte nastavit vzhled sestavy. Hlavní část sestavy je oblast Detail. Tato oblast je vytištěna jednou pro každý záznam hlavní tabulky. Chcete-li přidat oblast Detail stiskněte tlačítko btn1 a klikněte někam na vaši zprávu. Zobrazí se okno pro úpravu vlastností oblasti. Nyní zvolte "Detail" jako typ oblasti.

Přidání datových polí:

Po přidání oblasti Detail kapela do sestavy, musíte vložit datová pole, která chcete vytisknout. Stisknutím tlačítka btn11 a klinutím na oblast Detail vložíte nový prvek do oblasti. V zobrazeném okně vyberte datové pole, které chcete používat, a v případě potřeby nastavte jeho zarovnání, písmo a další možnosti. Nyní můžete přesouvat a měnit velikost datového pole pomocí myši.

Opakujte tyto kroky u všech datových polí, které chcete vytisknout. Níže je zobrazen příklad jak může oblast Detail vypadat po vložení všech datových polí:

Můžete použít funkci zarovnání prvků. Řekněme, že chcete, aby všechny prvky byly ve stejné vertikální poloze. Nejprve vyberte všechny prvky které chcete zarovnat ([Shift] + levé tlačítko myši). Poté stiskněte tlačítko [image] pro vyrovnání horních okrajů všech vybraných prvků.

Náhled:

Při navrhování sestavy byste často měli kontrolovat výsledný tisk pomocí tlačítka náhled

Pokračovat na Krok 4: Přidání oblasti Skupina


Krok 4: Přidání oblasti Skupina

Můžete si vytvořit mnohem přehlednější seznam rozdělený do odstavců. Například seznam adres může být strukturován podle prvního písmene názvu. K tomuto účelu můžete použít oblast Skupina:

Chcete-li vložit oblast Skupina, stiskněte tlačítko btn4 a klikněte na vaši zprávu. Pak je nutné nastavit položku "Master" - tabulka podle níž bude skupina fungovat. Oblast Skupina bude nyní kontrolovat nastavenou hodnotu v políčku "Group by field or expression" a při každé změné výsledné hodnoty bude oblast vytištěna. Pokud tedy chceme v oblasti tisknout první písmena názvu, musíme do pole "Group by field or expression" vložit výraz "Copy (Customers.Company, 1,1)" (pro více informací viz kapitola výpočtová pole). Klikněte na "OK".

Nyní jste přidali oblast Skupina do sestavy. Podívejte se na náhled sestavy a uvidíte, že oblast Skupina je vložena před každé nové první písmeno z názvu společnosti. Tato oblast Skupina ale bude mít za následek pouze několik prázdných řádků, protože neobsahuje žádné tiskové prvky. Proto můžeme do této oblasti přidat přidat popisky, výpočtová pole nebo jakékoliv jiné prvky. Například pokud chcete v této oblasti vytisknout první písmeno názvu, je nutné přidat výpočtové pole a zadat mu hodnotu "Copy (Customers.Company, 1,1)". Pravý obázek zobrazuje seznam bez skuoin, levý s vloženou oblastí Skupina a s jedním výpočtovým polem:

Pokračovat na Krok 5: Záhlaví stránky, názvy oblastí a celkové součty


Krok 5: Záhlaví stránky, názvy oblastí a celkové součty

Nyní máte hotovou sestavu, která obsahuje seznam adres z tabulky. Rozložení je již docela použitelné a náhled může vypadat třeba takto:

Chybí už jen grfická úprava nadpisu na první stránce a záhlaví stránky s popiskem pro každé datové pole. Sestava může také obsahovat nějaké shrnutí na konci zprávy, které například představuje celkový počet vytištěných záznamů.

Záhlaví stránky:

Každá stránka této sestavy by měla obsahovat záhlaví sloupců - měl by tam být velký popisek s názvem každého datového sloupce.

Nejprve pomocí tlačítka btn1 vytvořte novou oblast a její typ zvolte na "Záhlaví stránky". Nyní do oblasti vložte popisky pro každý sloupec s textem odpovídajícímu názvu sloupce.

Příklad:

Chcete-li nastavit větší velikost písma, tučné písmo styl nebo jiné písmo, můžete vybrat všechny prvky a nastavit požadované atributy písma v panelu nástrojů.

Záhlaví sestavy:

Na první stránku této sestavy je možné vložit hlavní nadpis tak, že vytvoříte novou oblast "Záhlaví sestavy". Pak na ni přidáte popisek a nastavíte velikost písma apod. Navíc můžete přidat aktuální datum a čas tisku. tuto informaci vložíte na oblast tisku použitím tlačítka btn9, a nastavením jeho typu na "Datum / Čas". Nyní záhlaví sestavy vypadá takto:

Při zobrazení náhledu sestavy si můžete všimnout následujícího problému: záhlaví stránky se popisky jednotlivých sloupců se zobrazí na první stránce ještě před hlavním nadpisem celé sestavy (stejně jak jsou za sebou videt oblasti v editoru sestav). Tento problém můžete odstranit tím, že nastavíte oblasti "záhlaví stránky" aby se netiskla na první stránce. Nejprve tedy vyberte oblast "záhlaví stránky" a dvojklikem otevřete její vlastnosti. Zaškrtněte vlastnost "Ne na první stránce".

Pak ovšem zase není vidět zádný popis sloupců na první stránce. Proto jednoduše zkopírujte všechny popisky z oblasti "záhlaví stránky" do oblasti "záhlaví sestavy".

Celkové součty:

Chcete-li přidat celkové shrnutí na konec sestavy, vložte novou oblast do sestavy a nastavte její typ na "Celkové součty". Nyní můžete nové systémové pole a zadat mu aby zobrazovalo například celkový počet rádků.

Celý vzhled sestavy by mohl vypadat takto:

Výsledný tiskový výstup:


Standardní oblasti (zahlaví, detail...)

btn1 Standardní oblasti (zahlaví, detail...)

 Nahoru Předchozí Další

Všechny standardní oblasti sestavy se vytvářejí stejným tlačítkem (viz výše). Typ oblasti je pak určen v zobrazeném okně vlastností oblasti.

K dispozici jsou následující typy oblastí:

• Záhlaví sestavy: tato oblast bude vytištěna na první straně sestavy jako nadpis sestavy

• Záhlaví stránky: záhlaví stránky je vytištěno v horní části každé stránky sestavy

• Záhlaví sloupců: záhlaví sloupce se používá u sestav s více sloupci (lze nastavit v menu "Sestava | Volby").

• Detail: oblast Detail je nejdůležitější sekce sestavy. Oblast je vytištěna jednou pro každý řádek hlavní tabulky sestavy.

• Záhlaví skupiny: oblast je vytištěna na začátku každé skupiny. Více informaci o skupinách naleznete v kapitole oblast Skupina

• Pata skupiny: pata skupiny je vytištěna na konci každé skupiny - tedy před začátkem nové skupiny. Více informaci o skupinách naleznete v kapitole oblast Skupina.

• Celkové součty: oblast je vytištěna na konci sestavy, po vytištění všech datových záznamů.

• Pata stránky: je vytištěno ve spodní části každé stránky sestavy

Všechny oblasti používají k nastavování vlastností stejné okno. Lze nastavi tyto vlastnosti:

Typ: typ oblasti (viz výše)

Barva: barva pozadí oblasti

Tisk

• ne na první stránce: oblast se tiskne pouze na druhou a další stránky

• ne na poslední stránce: potlačuje tisk oblasti na poslední stránku sestavy

• pouze sudé stránky: tisk pouze na sudých stránkách sestavy

• pouze liché stránky: tisk pouze na lichých stránkách sestavy

• dole na stránce: oblast je vytištěna v dolní části stránky nezávisle na předchozích oblastech

• nová stránka: před tiskem oblasti se vytvoří nová stránka

• nový sloupec: před tiskem oblasti se vytvoří nový sloupec (při použití sestavy s více sloupci)

Tiskni je-li výraz pravdivý:

Výraz je možné použít k určení, zda bude oblast vytištěna nebo ne. Výraz musí mít logický výsledek "ano" nebo "ne". Pro úpravu výrazu stiskněte tlačítko na pravé straně.

Rám:

Orámování oblasti. Můžete si vybrat, typ orámování, barvu, styl a šířku.


Oblast Poddetail

btn3 Oblast Poddetail

Oblast Poddetail vlastně jakási oblast detail, ale je podřízena skutečné oblasti detail. Například pokud chcete vytisknout seznam audio CD, a pro každé CD ještě seznam skladeb, můžete použít sekci Poddetail právě pro tisk seznamu skladeb. Pro tisk takovéhoto seznamu je však nutné mít připravené propojení další datové tabulky na hlavní tabulku sestavy. Toto propojení lze vytvořit v nastavení databáze.

Vlastnosti oblasti Poddetail:

Tabulka:

Datová tabulka ze které jsou tisknuta data v oblasti poddetailu.

Barva: barvu pozadí zprávy kapely.

Řídící:

Nadřízená tabulka. Pro každý záznam v nadřízené tabulce bude vytisknuta oblast poddetail.

Tisknout pouze je-li výraz pravdivý: viz Standardní oblasti

Tisk

• Před řídící oblastí detailu: tiskne oblast poddetail ještě před tiskem nadřízeného záznamu

• Dole na stránce: přesune oblast až na konec stránky

• Tisknout záhlaví/patu když je tabulka prázdná: záhlaví a pata oblasti poddetail bude vytištěn, i když nejsou k dispozici žádné datové záznamů pro tisk

• Nová stránka: vytvoření nové stránky před tiskem oblasti

• Nový sloupec: před tiskem oblasti se vytvoří nový sloupec (při použití sestavy s více sloupci)

Oblast záhlaví:

Vyberte oblast, která bude vytištěna jako hlavička před záznamy poddetailu.

Oblast paty:

Vyberte oblast, která bude vytištěna jako patička záznamů poddetailu.

Obrys: viz Standardní oblasti


Oblast Skupina

btn4 Oblast Skupina

Oblast Skupina se používá rozlišení tisknutých dat podle skupin. Například, pokud chcete vytisknout seznam jmen, můžete přidat oblast Skupina pro vytištění prvního písmene jména. Tisková sestava pak bude obsahovat např. písmeno "A" a následovat budou všechna jména začínající na "A". Pak písmeno "B" a opět jména začínající na "B"...atd. Důležité ovšem je, že data musí výt (v tomto případě) již v tabulce seřazena podle abecedy. Samotné vložení oblasti Skupina ješte nezajistí fyzické seřazení záznamů v databázi.

Příklady

Vnitřně oblast Skupina unguje následovně: Před tiskem záznamu je vždy uložen výsledek výrazu (vlastnost oblasti Skupina - ziv níže). Při každém dalším tisku datového záznamu se vždy zkontroluje, zda se nový výsledek liší od posledního. V případě ano, oblast Skupina je vytištěna, pokud ne, oblast se netiskne. Tímto způsobem mohou být data seskupena velmi flexibililně, protože výraz můžete použít téměř pro jakýkoli druh výpočtu.

Vlastnosti oblasti Skupina:

Master:

Určuje hlavní tabulku oblasti. Může jí být hlavní tabulka oblasti Detail nebo Poddetasil. Výraz Skupiny je kontrolován vždy, když se tiskne záznam z hlavní tabulky Skupiny.

Barva:

barva pozadí oblasti

Group-by field or expression:

výraz určující, zda bude oblast Skupina vytištěna či nikoli.Oblast bude vytištěna pokaždé, když se výsledek výrazu změní.

Tisk

• Nová stránka: vytvoření nové stránky před tiskem oblasti

• Nový sloupec: před tiskem oblasti se vytvoří nový sloupec (při použití sestavy s více sloupci)

• Dole na stránce: přesune oblast až na konec stránky

• Znovu tisknout na nové stránce tato volba zajistí tisk skupiny na nové stránce i pokud se hodnota výrazu nezměnila

Obrys: viz Standardní oblasti


Oblast Skupina - příklad

Následující obrázek ukazuje sestavu s oblastí Skupina (tučně vytištěné první znaky ze jména) a sestavu bez oblasti Skupina.


Oblast Dítě

btn2 Oblast Dítě

Dítě je oblast, která je připojena k jiné oblasti sestavy a je vytištěna vždy pod touto nadřízenou oblastí. Tímto způsobem můžete například vytisknout další oblasti po každé oblasti Detail. Výhodou použití oblasti Dítě namísto pouhého zvětšení velikosti nadřízené oblasti je, že můžete například tisknout oblast Dítě na novou stránku. Další výhodou je možnost tisku oblasti Dítě nezávisle na to zda byla vytištěna nadřízená oblast.

Oblast Dítě použijte také pokud máte na sestavě prvky s nastaveným "automatickým roztažením".

Vlastnosti oblasti Dítě:

Rodičovská oblast: nadřízená oblast na kterou je oblast Dítě připojena

Barva:

barva pozadí oblasti

Tisk

• ne na první stránce: oblast se tiskne pouze na druhou a další stránky

• pouze sudé stránky: tisk pouze na sudých stránkách sestavy

• pouze liché stránky: tisk pouze na lichých stránkách sestavy

• Dole na stránce: přesune oblast až na konec stránky

• Nová stránka: vytvoření nové stránky před tiskem oblasti

• Nový sloupec: před tiskem oblasti se vytvoří nový sloupec (při použití sestavy s více sloupci)

Tisknout pouze je-li výraz pravdivý:

Výraz lze použít k určení, zda bude oblast vytištěna či nikoli.

Obrys: viz Standardní oblasti


Datové pole

btn11 Datové pole

Datové ple zobrazuje data z tabulky nebo dotazu. Může jít o číselné údaje, znaky nebo více řádků textu.

Vlastnosti datového pole:

Datové pole:

Vyberte tabulku a sloupec, který chcete vytisknout.

Zarovnání:

text prvku může být zarovnán vlevo, vpravo nebo na střed.

Formát zobrazení:

číslená data mohou být formátavána do určítého tvaru

Písmo:

písmo textu prvku

Barva:

barva pozadí prvku (barvu písma lze nastavit přes tlačítko "Písmo").

Automatické zalamování:

Nastavte tuto volbu pokud chcete, aby byl text zalomen na další řádek pokud se nevejde nastavené šířky prvku (podobně jako textový procesor MSWord).

Průhledné:

tato volba zajistí průhledné pozadí vytištěného prvku

Auto šířka:

tato možnost změní velikost pravku podle šířky tištěného textu. Pokud tato volba není aktivovaná a text přesahuje šířku prvku, je oříznut.

Roztáhnout na výšku:

pokud obsahuje text více řádků (např. memo sloupec) je výška prvku automaticky upravena.

Potlačit tisk opakujících se hodnot:

aktivujte tuto volbu, pokud nechcete opakovaně tisknout zánamy se stejnými hodnotami. Vytiskne se vždy první záznam a dokud se hodnota sloupce nezmění, nebude se tisknout nic.

Potlačit tisk je-li hodnota pole 0

tato volba potlačuje tisk číselných polí pokud se jejich hodnota rovná nule.

Znovu tisknout na nové stránce

je-li aktivované "Potlačit tisk opakujících se hodnot", můžete touto volbou zajistit, že se pole na nové stránce vytiskne i pokud se hodnota nezměnila

Opakovat tisk na nové skupině

stejné jako "Znovu tisknout na nové stránce", ale pro skupiny.


Nadpis - text

btn5 Nadpis - text

Nadpis (popisek, návěští) tiskne statický text, tedy text, který je vytištěn přesně tak, jak je zobrazen v průběhu návrhu sestavy.

Vlastnosti nadpisu:

Text:

Jednořádkový text, který by měl být vytištěn. Pro delší texty je možné použít víceřádkové texty.

Rotace:

Otáčení textu v rozmezí 0 až 360 stupňů. Například 90 stupňů znamená zobrazování textu vertikálně.

Písmo:

Písmo textu

Barva:

Barva pozadí prveku (barvu písma lze nastavit tlačítkem "Písmo").

Zarovnání:

Zpráva prvku text může být zarovnán vlevo, vpravo nebo na střed.

Automatické zalamování:

Nastavte tuto volbu pokud chcete, aby byl text zalomen na další řádek pokud se nevejde nastavené šířky prvku (podobně jako textový procesor MSWord).

Průhledné:

tato volba zajistí průhledné pozadí vytištěného prvku

Auto šířka:

tato možnost změní velikost pravku podle šířky tištěného textu. Pokud tato volba není aktivovaná a text přesahuje šířku prvku, je oříznut.

Roztáhnout na výšku:

pokud obsahuje text více řádků (např. memo sloupec) je výška prvku automaticky upravena.


Víceřádkový text

btn6 Víceřádkový text

Víceřádkový text se používá pro tisk textu, který má více než jeden řádek. Stejně jako prvek "nadpis" zobrazuje text v jedné barvě a písmu. Pokud chcete tisknout formátovaný text, můžete použít prvek Richtext - formátovaný text.

Vlastnosti nadpisu:

Text:

Text, který by měl být vytištěn

Písmo:

Písmo textu

Barva:

Barva pozadí prveku (barvu písma lze nastavit tlačítkem "Písmo").

Zarovnání:

Zpráva prvku text může být zarovnán vlevo, vpravo nebo na střed.

Automatické zalamování:

Nastavte tuto volbu pokud chcete, aby byl text zalomen na další řádek pokud se nevejde nastavené šířky prvku (podobně jako textový procesor MSWord).

Auto šířka:

tato možnost změní velikost pravku podle šířky tištěného textu. Pokud tato volba není aktivovaná a text přesahuje šířku prvku, je oříznut.

Roztáhnout na výšku:

pokud obsahuje text více řádků (např. memo sloupec) je výška prvku automaticky upravena.


Obrázek

btn7 Obrázek

Prvek Obrázek je bitmapa ze souboru BMP vložená do sestavy.


Obrázek z databáze

btn12 Obrázek z databáze

Zatímco prvek "Datové pole" slouží pro zobrazení textu z databáze, můžete použít tento prvek pro zobrazení obrázků, které jsou uloženy přímo v databázi.

Vlastnosti prvku:

Sloupec z tabulky:

Tabulka a sloupec které obsahuje obrázek (pokud není ve formátu bitmap, nic se netiskne).

Roztáhnout obrázek automaticky:

Tato možnost zobrazí obrázek roztažený přesně podle velikosti prvku

Vystředit obraz:

Pokud je prvek větší než obrázek a tato volba je aktivována, obraz bude zobrazen uprostřed prvku. Jinak se zbrazí v levém horním rohu.

Zarovnání:

Zarovná obraz k okraji


Výpočtové pole

btn10 Výpočtové pole

Výpočtová pole (výrazová pole) se používají pro zobrazení textu, který se vypočte z výrazu nebo vzorce. Je možné je využít pro numerické výpočty, manipulaci s textovými řetězci, rozdělení datových polí tabulky a mnoho dalšího.

Výraz:

Tento výraz je vyhodnocen pokaždé, když má být výpočtové pole vytištěno (viz kapitola syntaxe výrazu).

Formát:

Numerická pole tabulky mohou být formátovány podle přesných pravidel (definice formátu)

Písmo:

Písmo textu

Barva:

Barva pozadí prveku (barvu písma lze nastavit tlačítkem "Písmo").

Řídící:

Pokud váš výraz používá nějaké agregační funkce, je nutné určit řídící tabulku výrazu která bude použita k aktualizaci výrazu. Pokaždé, když se změní záznam v této tabulce bude výraz přepočítán

Zarovnání:

Zpráva prvku text může být zarovnán vlevo, vpravo nebo na střed.

Rotace:

Otáčení textu v rozmezí 0 až 360 stupňů. Například 90 stupňů znamená zobrazování textu vertikálně.

Auto šířka:

tato možnost změní velikost pravku podle šířky tištěného textu. Pokud tato volba není aktivovaná a text přesahuje šířku prvku, je oříznut.

Roztáhnout na výšku:

pokud obsahuje text více řádků (např. memo sloupec) je výška prvku automaticky upravena.

Automatické zalamování:

Nastavte tuto volbu pokud chcete, aby byl text zalomen na další řádek pokud se nevejde nastavené šířky prvku (podobně jako textový procesor MSWord).

Průhledné:

tato volba zajistí průhledné pozadí vytištěného prvku

Vynulovat po tisku:

Pokud používáte výpočty SUM nebo COUNT z tabulky můžete použít tuto volbu k nastavení hodnoty na nulu po tisku prvku.


Agregační funkce

Agregační funkce jsou funkce, která počítají výslednou hodnotu přes více datových záznamů - například "součet" nebo "průměr".


Tvar

btn8 Tvar

Tento prvek se používá pro kreslení (horizontální nebo vertikální), čáry, kruhu a obdélníku.

Vlastnosti prvku

Typ:

Vykreslený tvar - kruh, čtyřúhelník, vodorovná čára, svislá čára nebo horní/dolní a levá/pravá čára.

Štětec:

• Styl: různé styly vyplnění kruhu nebo obdélníku

• Barva: barva, která je použita k vyplnění tvaru

Pero:

• Šířka: šířka čáry tvaru

• Styl: pevné, tečkované nebo čárkované čáry

• Barva: barva čar

• Mód: různé druhy čar


Systémové pole

btn9 Systémové pole

Tento prvek se používá pro zobrazení různých systémových informací - např aktuální čas a datum, číslo stránky apod.

Vlastnosti prvku:

Text:

Tento text se zobrazí před vlastní systémovou informací. Například text "Sestava vytištěna dne:" při tisku aktuálního data.

Typ:

Typ tisknuté systémové informace

• Datum: aktuální datum tisku sestavy

• Čas: aktuální čas tisku sestavy

• Datum a čas: aktuální datum a čas

• Počet řádků: Celkový počet datových záznamů

• Číslo řádku: aktuální počet datových záznamů

• Číslo stránky: aktuální číslo stránky

• Název sestavy: názvem přehledu, který lze nastavit pomocí položky menu "Sestava | Volby"

Auto šířka:

tato možnost změní velikost pravku podle šířky tištěného textu. Pokud tato volba není aktivovaná a text přesahuje šířku prvku, je oříznut.

Průhledné:

tato volba zajistí průhledné pozadí vytištěného prvku

Písmo:

Písmo textu

Barva:

Barva pozadí prveku (barvu písma lze nastavit tlačítkem "Písmo").


Richtext - formátovaný text

btn13 Richtext - formátovaný text

Prvek RichText (RTF) je tiskový prvek, který může zobrazovat víceřádkový text obsahující různá písma, barvy a formátování.

Pro úpravu RTF textu se vždy zobrazí speciální okno s pokročilým textovým editorem.

Další vlastnosti:

Barva:

barvu textu - pokud není nastavená přímo v editoru

Roztáhnout na výšku:

Pokud text obsahuje více rádků, tato volba zajistí správné vertikální roztažení prvku.


Richtext z databáze

btn14 Richtext z databáze

Tento prvek zobrazí Richtext (RTF) z datového pole tabulky.

Vlastnosti prvku:

Datové pole:

Výběr tabulky a pole z tabulky

Zarovnání:

Zpráva prvku text může být zarovnán vlevo, vpravo nebo na střed.

Písmo:

Písmo textu

Barva:

Barva pozadí prveku (barvu písma lze nastavit tlačítkem "Písmo").

Roztáhnout na výšku:

Pokud text obsahuje více rádků, tato volba zajistí správné vertikální roztažení prvku.


Formátování polí

Formátování číselných, datumových nebo časových polí

Numerická, datumová nebo časová pole mohou být zobrazeny mnoha různými způsoby. Zobrazní se řídí podle formátovacího řetězce - popis formátu pomocí zástupných znaků.

Numerická pole:

Příklady formátovacího řetězce

Formátované hodnoty

123 -123 0.5 0

řetězec: výsledek:

0 123 -123 1 0

0.00 123.00 -123.00 0.50 0.00

#.## 123 -123 .5

#,##0.00 1,23.00 -1,23.00 0.50 0.00

#,##0.00 kč 1,23.00 kč -1,23.00 kč 0.50 kč 0.00 kč

#,##0.00;(#,##0.00) 1,23.00 (1,23.00) 0.50 0.00

#,##0.00;;Zero 1,23.00 -1,23.00 0.50 Zero

0.000E+00 1.23E+03 -1.23E+03 5.000E-01 0.000E+00

#.###E-0 1.23E3 -1.23E3 5E-1 0E0

Datum/Čas:

Seznam specifikátorů:

d den bez úvodní nuly (1-31)

dd den včetně úvodní nuly (01-31)

ddd zkrácený název dne v týdnu

dddd plný název dne v týdnu

m měsíc bez úvodní nuly (1-12)

mm měsíc včetně úvodní nuly (01-12)

mmm zkrácený název měsíce

mmmm plný název měsíce

yy rok bez úvodního dvojčíslí (00-99)

yyyy kompletní rok (0000-9999)

h hodina bez úvodní nuly (0-23)

hh hodina včetně úvodní nuly (00-23)

n minuty bez úvodní nuly (0-59)

nn minuty včetně úvodní nuly (00-59)

s sekundy bez úvodní nuly (0-59)

ss sekundy včetně úvodní nuly (00-59)

z milisekundy bez úvodní nuly (0-999)

zzz milisekundy včetně úvodní nuly (000-999)

Příklad formátovacího řetězce

dd.mm.yy výsledek 05.12.06

(velikost písmen nehraje u specifikátorů vliv).


Výpočtové syntaxe

Výrazy se používají pro výpočetní oprerace s numerickými hodnotami, texty nebo logickými hodnotami ("ano" nebo "ne"). Pro tvorbu výrazu je možné využít řadu různých operátorů a funkcí víceméně srovnatelných s programovacím jazykem (v tomto případě "Pascal"). Z numerických hodnot je možné počítat například výši daně, textové řetězce je možné různě spojovat apod.

Upozornění: pokud je výraz součástí oblasti "Skupina" je nutné aby vracel logickou hodnotu. Oblast "Skupina" se pak podle výsledku tohoto výrazu buď tiskne, nebo ne.

Skládání výrazu

Výraz pracuje se čtyřmi typy dat: Strings (znaky), Integer (celé číslo), Float (desetinné číslo) a Boolean (logická). Binární data a memo pole nejsou ve výrazech podporované.

Seznam typu datových sloupců pouzívaných databází:

Typ ve výrazu | Datový typ databází
String | pole typu date, time, datetime
Integer | pole typu byte, integer, word
Float | pole typu currency, float
Boolean | pole typu boolean

Syntaxe výrazu je velmi podobná jako u programovacího jazyka Object Pascal.

Seznam podporovaných operátorů:

Operátor | Popis
+ | Přidat
- | Odečíst
* | Násobit
/ | Dělit
() | Závorky
And | Logické AND
Or | Logické OR
Not | Logické NOT
= | Rovno
< | Menší než
> | Větší než
<= | Menší než nebo rovno
>= | Větší než nebo rovno
<> | Nerovná

Standardní funkce jsou:

Funkce | Popis
Date | Aktuální datum jako řetězec
Time | Aktuální čas jako řetězec
Str(Number) | Převede číselný argument na řetězec
Copy(Str,s,l) | Vrací podřetězec str (od S-tého znaku, vrací maximálně l znaků)
Int(Number) | Vrací celou část čísla
Frac(Number) | Vrací desetinnou část čísla
If (Expr, r1, r2) | Vrací r1 nebo r2 v závislosti na výsledku Expr
TypeOf(Expr) | Vrací datový typ výraz
Sqrt(Number) | Vrací odmocninu z čísla
True | Vrací logickou hodnotu ANO
False | Vrací logickou hodnotu NE
Sum(Expr) | Vrací součet z Expr
Count | Vrací počet
Min(Expr) | Vrací nejnižší hodnotu z Expr
Max(Expr) | Vrací nejvyšší hodnotu z Expr
Average(Expr) | průměr z Expr

Použití databázových polí ve výrazech

Všechna pole v kterékoli tabulce je možné použít při tvorbě výrazu. Na název datového pole tabulky lze odkazovat buď jen samotným názvem (např. Adresa) nebo názvem tabulky následovaným tečkou a názvem pole (např. Zakaznici.Adresa). Pokud nezadáte název tabulky bude datové pole vyhledáváno ve všech dostupných tabulkách.

Aktuální verze výrazů nepodporuje názvy polí s vloženými speciálními znaky jako mezera, "/", tečka, znak dolaru a tak dále.

Použití textových řetězců ve výrazech

Řetězce by měl být zapisován v apostrofech. Následující text výrazu je správný:

"Počítače jsou skvělé!"

Maximální délka řetězce je 255 znaků.

Příklady výrazů

Níže jsou uvedeny některé příklady výrazů:

Výraz | Popis
1 | celočíselná konstanta, vrací 1
1.5 | konstanta s plovoucí čárkou, vrací 1.5
"Delphi" | řetězcová konstanta, vrací "Delphi" jako řetězec
True | logická konstanta, vrací ANO
1 + 2 | numerický výpočet, vrátí 3
2 * (3 + 2.5) | numerický výpočet, vrací 11
"Delphi" + " is great" | spojení řetězců, vrací řetězec "Delphi is great"
Name | vrací hodnotu sloupce Name, pokud v tabulce existuje
Customer.Name | vrací hodnotu sloupce Name v tabulce Customer
Name + " " + Contact | přidá mezeru mezi pole Name a Contact
AmountPaid * TaxRate / 100 | číselný výpočet mezi sloupci tabulky
"Printed "+ Date | vrací řetězec "Printed " (a dnešní datum)
"Total amount paid is " + str(AmountPaid) | sloučení řetězců (druhý řetězec vytvořený funkcí str)
if(AmountPaid > 5000, "Large order", "Small order") | vrací hodnotu ze sloupce "Largeorder" pokud hodnota sloupce "AmountPaid" je větší než 5000. Jinak vrací hodnotu sloupce "Smallorder"
if(CheckField, "X", " ") | Tiskne "X" je-li CheckField pravda

Vizuální tvorba výrazů

Výrazy mohou být zapisované buď přímo na odpovídajícího řádku, nebo můžete stisknout tlačítko "..." pro zobrazení Průvodce sestavením výrazu. Pak je možné vizuálně vytvářet výraz i pomocí myši. Je-li použita funkce do které je nutné předat nejaké parametry (například "Copy" nebo "SUM"), objeví se další okno průvodce pro definování těchto parametrů zvlášť.


Používání parametrů v SQL dotazech

Pokud jste zvyklí na SQL, víte, že SQL příkaz může mít parametry. Editor sestav umožňuje vkladání parametrů do SQL také. Následující příklad ukazuje SQL dotaz, který má parametr "CustomerNo" (je nutné parametry zapisovat spolu s ":"):

Nyní můžete stisknutím tlačítka "Parametry" otevřít následující okno:

Zde si můžete určit druh parametru:

Hodnota: stálá hodnota použitá při generování sestavy

Zadat hodnotu před tiskem: Pomocí této možnosti bude před každým tiskem zobrazen dotaz na zadání hodnoty parametru. Tímto způsobem lze individuálně filtrovat data před každým tiskem sestavy.

Přiřadit hodnotu z řídící tabulky: Tato volba umožňuje získat hodnotu parametru z jiného datového souboru což znamená, že název parametru MUSÍ odpovídat názvu sloupce v jiné datové tabulce nebo dotazu. Současně je nutné nastavit položku "Řídící" vpředchozím okně tvorby SQL dotazu.


Menu "Zobrazit | Volby"

Zobrazit měřítka
Aktivujte tuto možnost pro zobrazení mřížky při editaci sestavy. Tato mřížka usnadní pohyb a vyrovnání prvků sestavy.

Jednotka
Jednotka, kterou editor sestav používá pro měření, zobrazování mřížky apod

Zobrazit názvy oblastí
Tato volba povolí zobrazení názvů oblastí v návrhovém režimu. Názvy oblastí samzřejmě nejsou tisknuté.

Písmo
Písmo pro zobrazení názvu oblasti.

Velikost mřížky
Nastaví (neviditelné) mřížky na kterou jsou prvku sestavy autoamticky zarovnávané. Mřížku můžete použít pro snadnější zarovnání prvků na stejnou horizontální nebo vertikální pozici. Poznámka: Prvek je ale možné posunovat i jenodlivé pixely - pokud při změně pozice podržíte klávesu Shift

Mřížka z klávesnice
Stejné jako předchozí ale pro pohyb prvků pomocí kurzorových kláves na klávesnici namísto myší.

Zobrazit obrys komponent při návrhu
Pokud aktivujete tuto volbu, budou v režimu návrhu sestavy zobrazené čárkované obrysy jenotlivých prvku. Rámy jsou vidět pouze v režimu návrhu, nikoli při tisku.


Položka menu "Sestava | Volby"

Název sestavy
Název které se objevuje v tiskovém manageru Windows. Také může být vytisknut v sestavé pomocí systémového pole

Orientace
Tato volba definuje celkovou orientaci pozadí sestavy

Velikost papíru
Definuje papír sestavy. Upozornění: ne všechny ovladače tiskáren podporují všechny velikosti papíru.

Okraje
Jedná se okraje na papíru. Minimální hodnoty, závisí na hardware vaší tiskárny.

Počet sloupců
To je počet sloupců zobrazených v sestavě.
Mezera mezi sloupci
Jedná se o prázdný prostor mezi sloupci, pokud používáte vícesloupečkovou sestavu.


Otázky a odpovědi, tipy a triky

 Nahoru Předchozí

Když jsem v náhledu sestavy nevidím všechny vodorovné čáry které mám vytvořené v sestavě. Proč?
Vodorovné čáry jsou tam pořád a budou vytištěné, pouze vlivem zobrazení (měřítka) nejsou právě na obrazovce viditelné (jsou příliš tenté).

Jak mohu tisknout pouze jeden datový záznam?
Zrušte hlavní datový soubor. Menu "Sestava | Tabulky databáze"